Gibson Brands Forums: cmd stuido 2a - Gibson Brands Forums

Jump to content

  • (2 Pages)
  • +
  • 1
  • 2
  • You cannot start a new topic
  • You cannot reply to this topic

cmd stuido 2a luces led

#21 User is offline   alvarohdez 

  • Member
  • Group: All Access
  • Posts: 11
  • Joined: 02-November 17

Posted 17 December 2017 - 11:00 AM

Hola Luis,

yo tenía exactamente el mismo problema de los LEDs en CMD studio 2A, tanto el pc con en el macbook.

Después de leer este hilo, descargué el CMD channel changer y al cambiarlo al canal 1, he conseguido que al conectar el controlador al pc, los botones se iluminen. Éxito!

Pero al hacer lo mismo en el mac, no he conseguido nada. Todos los LEDs siguen de color naranja. ¿Alguna solución?


A parte de esto, creo que tengo algunos problemas con el mapeo. Tanto en el pc como en el mac me ocurre que el crossfader principal del mixer actúa como el volumen del master, es decir, cuando muevo el fader hacia el deck A, deja de sonar la canción, aunque esté cargada en cualquiera de los dos decks.

También me pasa que en el deck A, al cambiar el modo a vinyl, cuando una canción se está reproduciendo, puedo hacer, digamos, backspin con el CMD rebobinado hacia atrás con el controlador del deck A como si se tratara de un tocadiscos físico, pero con el deck B no. Sólo ralentiza el tempo de la canción. No sé si me explico.

Siento el aluvión de preguntas. Pero necesito ayuda!


Un saludo y muchísimas gracias.
0

#22 User is offline   alvarohdez 

  • Member
  • Group: All Access
  • Posts: 11
  • Joined: 02-November 17

Posted 18 December 2017 - 09:30 AM

Buenas tardes,

respecto a mi anterior comentario, decir que he solventado el problema del crossfader.

El resto de los problemas persisten.

Un saludo!
0

#23 User is offline   Luis Serrano 

  • Moderator
  • Group: Gibson Pro Audio
  • Posts: 543
  • Joined: 30-April 15

Posted 18 December 2017 - 05:38 PM

alvarohdez said:

Pero al hacer lo mismo en el mac, no he conseguido nada. Todos los LEDs siguen de color naranja. ¿Alguna solución?

Asegúrate que en "Preferences->MIDI control" el puerto MIDI output esta activado (en color verde) y ademas donde se selecciona el controlador tienes que tener "output -> Studio2A". Te adjunto foto con la configuración correcta.
Attachment CMD4A_MIDI_settings.png

alvarohdez said:

También me pasa que en el deck A, al cambiar el modo a vinyl, cuando una canción se está reproduciendo, puedo hacer, digamos, backspin con el CMD rebobinado hacia atrás con el controlador del deck A como si se tratara de un tocadiscos físico, pero con el deck B no. Sólo ralentiza el tempo de la canción. No sé si me explico.

Pues pueden ser varias cosas, primero habrá que asegurarse que cuando tocas la parte metálica del jog el controlador envia un mensaje MIDI (...con el monitor de la seccion MIDI learn podrias verlo). Despues toca comprobar que el mensaje que envia el controlador es el mismo que en el MIDI mapping (Note number 0x33h).

Attached File(s)


0

#24 User is offline   alvarohdez 

  • Member
  • Group: All Access
  • Posts: 11
  • Joined: 02-November 17

Posted 04 January 2018 - 08:36 AM

Gracias por la respuesta Luis,

diría que esa es la configuración que tengo ahora mismo, pero mejor esta tarde lo compruebo en casa y te digo.

Respecto al vinyl mode, intentaré comprobar si envía señal MIDI como me has dicho, con el MIDI learn, aunque a priori no sé cómo.

Un saludo y muchas gracias. Y feliz año nuevo por cierto!
0

#25 User is offline   alvarohdez 

  • Member
  • Group: All Access
  • Posts: 11
  • Joined: 02-November 17

Posted 04 January 2018 - 09:05 AM

De todas formas, respecto al vinyl mode, estoy pensando que sí envía señal MIDI, ya que si ese canal está en stop, sí que puedo rebobinar perfectamente con el jog. El problema es cuando la canción está en reproducción, es entonces cuando no puedo hacer backspin, solo bajar el pitch, a no ser que lo haga muuuy despacio. En ese caso sí que puedo retroceder en la pista girando el jog hacia atrás. No sé, es algo raro, la verdad.
0

#26 User is offline   alvarohdez 

  • Member
  • Group: All Access
  • Posts: 11
  • Joined: 02-November 17

Posted 05 January 2018 - 06:38 AM

Buenos días, el problema de los LEDS en el macbook se ha solucionado sólo aparentemente, ayer cuando conecté el controlador al abrir el DD se iluminaron todas las luces con los diferentes colores. Supongo que será algo relacionado con reiniciar el ordenador después de ajustar la configuración.

Eso sí, el problema del jog B sigue igual. Ayer estuve probándolo bastante y no hay manera, con la opción vinyl apagada funciona perfectamente, aumenta o disminuye la velocidad del track exactamente igual que hace el jog A. Pero cuando está seleccionada esta opción, actúa de manera muy irregular, parece que se mezclaran los dos efectos aleatoriamente al hacer girar el jog. Rebobina y de repente ralentiza el pitch sin mucho sentido.

¿A qué se podría deber?


Un saludo y gracias.

Álvaro
0

#27 User is offline   alvarohdez 

  • Member
  • Group: All Access
  • Posts: 11
  • Joined: 02-November 17

Posted 22 January 2018 - 12:22 PM

Hola de nuevo Luis,

sigo con el mismo problema con el deck B. Es curioso, porque mientras está sonando el track, si tengo seleccionado el modo Vinyl, cuando toco el deck B, la canción se para, como previsiblemente debe ocurrir, pero si trato de hacer rewind o forward, entonces actúa como un cdj.

¿Alguna solución? ¿Dónde debo configurar esto?

Un saludo.

This post has been edited by alvarohdez: 22 January 2018 - 12:22 PM

0

#28 User is offline   Luis Serrano 

  • Moderator
  • Group: Gibson Pro Audio
  • Posts: 543
  • Joined: 30-April 15

Posted 06 February 2018 - 05:35 PM

He estado revisando el script MIDI para el CMD Studio 2A y todo parece estar bien. Uno de los problemas que tengo es que jamas he tenido este controlador así que tampoco puedo garantizar al 100% que el script funcione perfectamente.

Si el jog del deck A te funciona bien entonces sigo pensado que el problema puede ser que el sensor táctil del jog B no esta enviando el mensaje cuando lo tocas con el dedo. No me acuerdo si usas Windows o Mac pero podrias descargarte un programa monitor MIDI para comprobar que el sensor del jog B funciona bien, por ejemplo MIDIOX para Windows o MIDI monitor para MAC.
0

#29 User is offline   alvarohdez 

  • Member
  • Group: All Access
  • Posts: 11
  • Joined: 02-November 17

Posted 12 February 2018 - 01:10 PM

Hola Luis,

muchas gracias por responder. He descargado el MIDI monitor, ya que uso mac. Lo ejecuto y al mover el deck B me aparecen los siguientes mensajes, por ejemplo:

20:01:04.451 From Studio 2A Note On 1 D♯2 127
20:01:04.547 From Studio 2A Control 1 General Purpose 4 (fine) 65
20:01:04.587 From Studio 2A Control 1 General Purpose 4 (fine) 65
20:01:04.603 From Studio 2A Control 1 General Purpose 4 (fine) 65
20:01:04.635 From Studio 2A Control 1 General Purpose 4 (fine) 65
20:01:04.668 From Studio 2A Control 1 General Purpose 4 (fine) 65
20:01:04.748 From Studio 2A Control 1 General Purpose 4 (fine) 65
20:01:04.909 From Studio 2A Control 1 General Purpose 4 (fine) 65
20:01:05.262 From Studio 2A Note Off 1 D♯2 0

No sé si son correctos, la verdad es que no controlo apenas nada de MIDI.

Un saludo!
0

#30 User is offline   Luis Serrano 

  • Moderator
  • Group: Gibson Pro Audio
  • Posts: 543
  • Joined: 30-April 15

Posted 12 February 2018 - 02:26 PM

Gracias, puedo ver que al menos si que esta enviando un mensaje de touch pero me gustaría comprobar que los números que envía son los correctos. En el programa MIDI monitor entra en "preferences->display" y selecciona:
Note format -> Hexadecimal number
Controller format -> Hexadecimal number
Data format -> Hexadecimal number
Y muestrame los mensajes que recibes ahora al mover el jog.
0

#31 User is offline   alvarohdez 

  • Member
  • Group: All Access
  • Posts: 11
  • Joined: 02-November 17

Posted 13 February 2018 - 10:53 AM

Hola Luis,

he hecho los cambios que me dijiste en el panel de preferencias de MIDI Control.

Los mensajes que recibo son estos:

17:50:51.854 From Studio 2A Control 1 $33 $3F
17:50:51.886 From Studio 2A Note On 1 $33 $7F
17:50:51.926 From Studio 2A Control 1 $33 $41
17:50:51.928 From Studio 2A Note Off 1 $33 $00
17:50:51.958 From Studio 2A Note On 1 $33 $7F
17:50:51.975 From Studio 2A Control 1 $33 $41
17:50:51.977 From Studio 2A Note Off 1 $33 $00
17:50:52.007 From Studio 2A Control 1 $33 $41
17:50:52.039 From Studio 2A Note On 1 $33 $7F
17:50:52.087 From Studio 2A Control 1 $33 $41
17:50:52.089 From Studio 2A Note Off 1 $33 $00
17:50:52.119 From Studio 2A Note On 1 $33 $7F
17:50:52.127 From Studio 2A Control 1 $33 $41
17:50:52.129 From Studio 2A Note Off 1 $33 $00
17:50:52.159 From Studio 2A Note On 1 $33 $7F
17:50:52.207 From Studio 2A Note Off 1 $33 $00

Un saludo y muchas gracias por la ayuda!
0

#32 User is offline   Luis Serrano 

  • Moderator
  • Group: Gibson Pro Audio
  • Posts: 543
  • Joined: 30-April 15

Posted 19 February 2018 - 04:41 PM

Los números de NN y CC son correctos pero veo algo raro en la ultima captura que me enviaste:

El sensor touch envía "Note On 1 $33 $7F" cuando lo tocas y "Note Off 1 $33 $00" cuando lo dejas de tocar... sin embargo, en la ultima captura estos dos mensajes se repiten todo el rato mientras girabas el jog (basándome en el tiempo de captura) y esto no es normal. La verdad es que no se que decirte, he revisado el código del programa varias veces y no encuentro ningún fallo lo que me hace pensar que el jog B de tu controlador no esta funcionando correctamente, pero claro lo del controlador tampoco lo puedo asegurar al 100%.
0

Share this topic:


  • (2 Pages)
  • +
  • 1
  • 2
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users