Gibson Brands Forums: DJC44 not working on MacOSX High Sierra - Gibson Brands Forums

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

DJC44 not working on MacOSX High Sierra

#1 User is offline   pimpf 

  • Newbie
  • Group: All Access
  • Posts: 3
  • Joined: 21-November 17

Posted 01 December 2017 - 08:33 AM

Hi everyone,

after upgrading to the latest Mac OS Release High Sierra I am no longer able to use the DJC4 as external soundcard. It is simply not being recognized as device anymore. I tried different cable, different port, etc.
I am using a MacBook Pro (Retina, Mid 2012), 2.6 GHz Intel Core i7, 16 GB 1600 MHz DDR3 along with a NVIDIA GeForce GT 650M 1 GB Intel HD Graphics 4000 1536 MB

Any ideas why that happened? Or did I probably miss an announcement?
Any help highly appreciated.
0

#2 User is offline   Luis Serrano 

  • Moderator
  • Group: Gibson Pro Audio
  • Posts: 537
  • Joined: 30-April 15

Posted 07 December 2017 - 10:36 AM

Hi,

I have updated my iMac (Retina 5K, 27", late 2015) to macOS High Sierra (v10.13.2) and the DJC.4 controller is working fine here.

Open the "Apple Menu > About this Mac > System Report > USB" and check that the DJC.4 controller appears in the USB device tree. If it is not in the list then I suggest to try another USB cable.
0

#3 User is offline   pimpf 

  • Newbie
  • Group: All Access
  • Posts: 3
  • Joined: 21-November 17

Posted 08 December 2017 - 12:33 AM

Hi Luis,

thanks for the hint. I did that, and guess what:

https://imgur.com/ClDMyRT

The DJC4 appears in that list, but is not selectable as output/input device. Its not selectable anywhere, because it simply doesn't appear anymore. Please note: I am currently using the device not as a midi controller, but as an external soundcard for recording my guitars and playing the output.
0

#4 User is offline   Luis Serrano 

  • Moderator
  • Group: Gibson Pro Audio
  • Posts: 537
  • Joined: 30-April 15

Posted 11 December 2017 - 03:47 AM

Hi,

Follow these steps:

1. On your Mac, navigate to "Utilities>Audio MIDI Setup".
2. Check that the DJC-4 appears in the "Audio Devices" window and the configuration is correct.

In case of MIDI problems:

3. Go to Window>Show MIDI Studio.
4. Try to remove the DJC-4 device.
5. Unplug and plug your DJC-4 device back into your computer.
0

#5 User is offline   pimpf 

  • Newbie
  • Group: All Access
  • Posts: 3
  • Joined: 21-November 17

Posted 15 December 2017 - 01:49 AM

Hi Luis,

first of all: I am very thankful that you take your time to respond to my posting. Thank you.

View PostLuis Serrano, on 11 December 2017 - 03:47 AM, said:

Hi,
Follow these steps:
1. On your Mac, navigate to "Utilities>Audio MIDI Setup".
2. Check that the DJC-4 appears in the "Audio Devices" window and the configuration is correct.

I think, thats exactly the problem. It doesn`t appear in that window. I only see the built-in devices for in/output, as well as my Soundflower "devices".
I got an Audio4DJ external soundcard, which actually works. Even though those devices are no longer properly supported by NI. Anyway, the DJC4 doesn't appear.

View PostLuis Serrano, on 11 December 2017 - 03:47 AM, said:

In case of MIDI problems:

3. Go to Window>Show MIDI Studio.
4. Try to remove the DJC-4 device.
5. Unplug and plug your DJC-4 device back into your computer.


Double-clicking the device indicates its "online". Whatever that means in that context, but maybe the midi in/out might work.
Is it possible that the internal soundcard of the djc4 simply died?
0

#6 User is offline   Luis Serrano 

  • Moderator
  • Group: Gibson Pro Audio
  • Posts: 537
  • Joined: 30-April 15

Posted 21 December 2017 - 06:25 PM

View Postpimpf, on 15 December 2017 - 01:49 AM, said:

Is it possible that the internal soundcard of the djc4 simply died?

I'm not really sure. I think that the best thing that you can do is to try the controller in another computer to check if the soundcard still works there. The strange thing is that it worked before your OS update, what makes me feel that the internal soundcard is ok.
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users