Gibson Brands Forums: GA-30RVT - 8 Tube version - Gibson Brands Forums

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

GA-30RVT - 8 Tube version

#1 User is offline   Steve36 

  • Newbie
  • Group: All Access
  • Posts: 4
  • Joined: 01-February 18
  • LocationOntario, Canada

Posted 02 February 2018 - 12:15 PM

Hello,

I was wondering if anyone has the schematic for the 8 Tube version of this amp? I can find the 9 tube version online only? I believe this is a 1962 model.

I was given a GA-30RVT vintage amp and it is beautiful. Unfortunately when I got it, it had been neglected and kept in a cold garage. I hooked up the speakers in series and turned it on. Unfortunately is started smoking. After further inspection, I could see damaged filter caps inside. I replaced them with ATOM Spragues. I also installed a 3 prong cord. After replacing the caps, when I first turned on the amp it made a speaker crackling noise, then no sound at all after a few seconds. The amp will power on and all the tubes glow but there is no output at all. No sound, no hum, nothing. I also realized that the speakers installed are not the originals and the 12" is 8ohm and the 10" is 4ohm ( measured resistance with a meter as it was not labelled). The speakers click with the battery test so they should be working. Could the 4ohm and 8ohm speaker combo caused more issues? Any advice would be appreciated. All the wiring inside looked good, aside from the filter caps being bad, nothing else looked melted or burned.


Thanks,


Steve.
0

#2 User is offline   Steve36 

  • Newbie
  • Group: All Access
  • Posts: 4
  • Joined: 01-February 18
  • LocationOntario, Canada

Posted 12 March 2018 - 10:13 AM

Just in case anyone has the same amp and issue. The culprit turned out to be the 1000 ohm ceramic power resistor. I replaced both (1K ohm, & 10K ohm) just in case and after that, the amp came to life again.

Also, the EA-12 Futura amp has the same 8 tube layout as this amp, so the schematic for this appears to match closely other than the fact it only has 1 speaker instead of 2. Gibson says they never made a schematic for this amp in 1962. Luckily I stumble on a thread that pointed me to the EA-12 futura schematic.
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users