Jump to content
Gibson Brands Forums

mastermind

Members
  • Content Count

    6
  • Joined

  • Last visited

Posts posted by mastermind


  1. If you push the platter then the LCD lines comes back, or the platter starts to spin again?
    If I push the platter, the platter ATTEMPTS to resume spinning but doesn't do so for long.

     

    I sent the faulty SCS.1d back to stanton on the 11/14/12 and I have not heard a word back since... not even to say that they have received it. I have tracked It through UPS (mail carrier) and they told me the package was received on 11/16/12 and it is now 11/25/12 and still no word.

     

    It seems to be not a time relevant thing (someone had it after purchase/ someone get them after 8 moths/2 years)
    Mine was bad the very first time I turned it on.

     

    And someone should take care of the f***ing customers. Who payed a LOT of money for something what DOESN'T work.

    What is Stanton waiting for? To get a few dozen of angry users, who goes to court because a thing was put into production which is faulty, and no customer care here?

    I'm at the point where I'm ready to complain directly to Gibson. I cannot believe a company as well known for quality as Gibson, could possibly allow such shabby treatment of it's customers.

    As I said, I am currently awaiting a status update on my RMA. Hopefully Stanton will do the right thing and address my issues ASAP...


  2. I can't get DaRouter to detect my SCS 1d decks or my SCS 1m controller on my 2010 2.8 ghz quad Mac pro (24 GB RAM) running OS X 10.7.5 . When I hook them up to my 2.8 ghz core duo imac (6GB RAM) running OS X 10.6.8 only one SCS 1d deck and the SCS 1m controller are detected. Darouter will not detect BOTH Decks at the same time. I don't know if this has anything to do with it, but the serial numbers for both of the decks and the controller read 00000 when Da Router does detect them. I believe all firmware is up to date (1.27 on the SCS 1ds and 1.24 on the SCS 1m), and I believe I am using the latest version of the DaRouter software (1.1.42). ANY Help would be greatly appreciated...

     

    (Edited ) Wow... Now the platter has stopped spinning on one of the decks and I've lost some pixels in on one of that deck's displays! If I push the platter sometimes it picks back up and at other times it doesn't. I have a call in with Stanton, hopefully they'll have an answer for me by tomorrow... Haven't had this many problems with equipment in ages....


  3. I can't get DaRouter to detect my SCS 1d decks or my SCS 1m controller on my 2010 2.8 ghz quad Mac pro (24 GB RAM) running OS X 10.7.5 . When I hook them up to my 2.8 ghz core duo imac (6GB RAM) running OS X 10.6.8 only one SCS 1d deck and the SCS 1m controller are detected. Darouter will not detect BOTH Decks at the same time. I don't know if this has anything to do with it, but the serial numbers for both of the decks and the controller read 0000 when Da Router does detect them. I believe all firmware is up to date (1.27 on the SCS 1ds and 1.24 on the SCS 1m), and I believe I am using the latest version of the DaRouter software (1.1.42). ANY Help would be greatly appreciated...

×
×
  • Create New...