Jump to content
Gibson Brands Forums
Sign in to follow this  
Respite

DJC.4 & Traktor Scratch Pro 2 CD Timecode Setup

Recommended Posts

Hello all,

 

I've been troubleshooting my setup for over a week now and Im slowing going crazy! I really hope someone out there can help!

 

I've been using the Stanton DJC.4 as a midi controller with Traktor Pro for about 6 months, and now I would like to incorporate my two Stanton C314 cd players into my setup. I upgraded to Traktor Scratch Pro 2, and purchased the latest Traktor timecode cds. When I hook everything up, my decks in Traktor show up as "Scratch Disabled", and in the configure window under Timecode Setup, all four decks show up as "Off". When I hit play on my cd players, I can see a small blue wave showing up beside each scratch calibrate circle in either deck, but it's looks like the signal is weak or broken. I've triple checked all my connections, I think the problem is lying in my configuration within Traktor, but I have no idea where. If anyone out there has any info to share that would be amazing. I go into details of my setup and configuration below, i've also attached a PDF of screencaps to make things clearer.

 

Hardware

- My cd players are connected to my DJC.4 via RCA cables, from the cd players' audio out's to the DJC.4 audio inputs 1 & 2.

- I have both inputs set to "Line", and the PC/Thru toggle switch is set to PC.

- The input 1 toggle switch is set to "Input 1/2", and the input 2 toggle switch is set to "Input 3/4"

- I'm confident the cd players are connected correctly, and I have tested input 1 by switching the PC/Thru toggle to "Thru", and I am able to hear the timecodes high-pitched tone come through when I play cd player 1.

 

Software

- (See screencap 1) In Traktor's preferences, under Audio Setup, I have the audio device set to DJC.4 (note that Phono/Line Input Channels show "Not Supported". I have seen this in other configurations, so I don't think this is the issue).

- (See screencap 2) Under Output Routing, my Mixing Mode is set to Internal, and my Output Monitor and Master are set to Back L/R and Front L/R, the same as when I use the DCJ.4 as a midi controller.

- (See screencaps 3, 4, 5 & 6) Under Input Routing, since there are only 4 options available in the dropdown, I select the first two for Deck A, and the second two for Deck B. This is not particularly intuitive, but when I test out each cd player one at a time, I do see a blue audio level showing up in each deck respectfully, which leads me to think this may be correct.

- (See screencaps 7) Under Timecode Setup, all four Decks are showing up as "OFF" for Timecode Inputs. I can see no way to change these, only select Scratch Control (which is currently selected) or Internal Playback.

 

Additional software details/screecaps

- Controller manager, screencap 8

- Full tractor view with cd players playing, screencap 9

 

Thank you so much for reading my novel! looking forward to hearing your suggestions!

 

Cheryl

screencaps.pdf

Share this post


Link to post
Share on other sites

Hello all,

 

I've been troubleshooting my setup for over a week now and Im slowing going crazy! I really hope someone out there can help!

 

I've been using the Stanton DJC.4 as a midi controller with Traktor Pro for about 6 months, and now I would like to incorporate my two Stanton C314 cd players into my setup. I upgraded to Traktor Scratch Pro 2, and purchased the latest Traktor timecode cds. When I hook everything up, my decks in Traktor show up as "Scratch Disabled", and in the configure window under Timecode Setup, all four decks show up as "Off". When I hit play on my cd players, I can see a small blue wave showing up beside each scratch calibrate circle in either deck, but it's looks like the signal is weak or broken. I've triple checked all my connections, I think the problem is lying in my configuration within Traktor, but I have no idea where. If anyone out there has any info to share that would be amazing. I go into details of my setup and configuration below, i've also attached a PDF of screencaps to make things clearer.

 

Hardware

- My cd players are connected to my DJC.4 via RCA cables, from the cd players' audio out's to the DJC.4 audio inputs 1 & 2.

- I have both inputs set to "Line", and the PC/Thru toggle switch is set to PC.

- The input 1 toggle switch is set to "Input 1/2", and the input 2 toggle switch is set to "Input 3/4"

- I'm confident the cd players are connected correctly, and I have tested input 1 by switching the PC/Thru toggle to "Thru", and I am able to hear the timecodes high-pitched tone come through when I play cd player 1.

 

Software

- (See screencap 1) In Traktor's preferences, under Audio Setup, I have the audio device set to DJC.4 (note that Phono/Line Input Channels show "Not Supported". I have seen this in other configurations, so I don't think this is the issue).

- (See screencap 2) Under Output Routing, my Mixing Mode is set to Internal, and my Output Monitor and Master are set to Back L/R and Front L/R, the same as when I use the DCJ.4 as a midi controller.

- (See screencaps 3, 4, 5 & 6) Under Input Routing, since there are only 4 options available in the dropdown, I select the first two for Deck A, and the second two for Deck B. This is not particularly intuitive, but when I test out each cd player one at a time, I do see a blue audio level showing up in each deck respectfully, which leads me to think this may be correct.

- (See screencaps 7) Under Timecode Setup, all four Decks are showing up as "OFF" for Timecode Inputs. I can see no way to change these, only select Scratch Control (which is currently selected) or Internal Playback.

 

Additional software details/screecaps

- Controller manager, screencap 8

- Full tractor view with cd players playing, screencap 9

 

Thank you so much for reading my novel! looking forward to hearing your suggestions!

 

Cheryl

 

 

Sorry for the delayed response i was out of the country traveling extensively, was this ever resolved?

I will have to check with NI but i fear that the soundcard within the C4 may not allow external timecode of Traktor 2. They (Traktor Scratch) like Serato scratch, require one of their devices to translate the timecode (and only one of their cards can do it).

 

Feel free to PM me your details so we can resolve.

 

GPA~DJ

Share this post


Link to post
Share on other sites

Sorry for the delayed response i was out of the country traveling extensively, was this ever resolved?

I will have to check with NI but i fear that the soundcard within the C4 may not allow external timecode of Traktor 2. They (Traktor Scratch) like Serato scratch, require one of their devices to translate the timecode (and only one of their cards can do it).

 

Feel free to PM me your details so we can resolve.

 

GPA~DJ

 

Thanks for your reply GPA-DJ! No the issue has not yet been resolved. I've been scouring online for over a week but have had a really hard time finding any info about this issue. If you're able to look into it with NI as you suggested, that would be a really big help! :)

 

Thanks again,

Cheryl

Share this post


Link to post
Share on other sites

Update!

 

I consulted with some pro audio guys and they've confirmed that yes, Traktor Scratch requires a Native Instruments soundcard, or a Traktor Scratch certified mixer to read Traktor Timecode. They did suggest that with a bit of hackery, one could get Traktor Scratch to work with a non-NI soundcard, but that it would take a little work to figure out and rig up. If anyone else out there is having this same issue, it would definitely be worth looking into hacking a solution. I myself am fortunate enough to have an Audio 4 soundcard, so I'm simply using that with my CD turntables, and running my DJC.4 as a midi controller in internal mixing mode.

 

Cheers!

C.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...