Jump to content
Gibson Brands Forums
Sign in to follow this  
pimpf

DJC44 not working on MacOSX High Sierra

Recommended Posts

Hi everyone,

 

after upgrading to the latest Mac OS Release High Sierra I am no longer able to use the DJC4 as external soundcard. It is simply not being recognized as device anymore. I tried different cable, different port, etc.

I am using a MacBook Pro (Retina, Mid 2012), 2.6 GHz Intel Core i7, 16 GB 1600 MHz DDR3 along with a NVIDIA GeForce GT 650M 1 GB Intel HD Graphics 4000 1536 MB

 

Any ideas why that happened? Or did I probably miss an announcement?

Any help highly appreciated.

Share this post


Link to post
Share on other sites

Hi,

 

I have updated my iMac (Retina 5K, 27", late 2015) to macOS High Sierra (v10.13.2) and the DJC.4 controller is working fine here.

 

Open the "Apple Menu > About this Mac > System Report > USB" and check that the DJC.4 controller appears in the USB device tree. If it is not in the list then I suggest to try another USB cable.

Share this post


Link to post
Share on other sites

Hi Luis,

 

thanks for the hint. I did that, and guess what:

 

https://imgur.com/ClDMyRT

 

The DJC4 appears in that list, but is not selectable as output/input device. Its not selectable anywhere, because it simply doesn't appear anymore. Please note: I am currently using the device not as a midi controller, but as an external soundcard for recording my guitars and playing the output.

Share this post


Link to post
Share on other sites

Hi,

 

Follow these steps:

 

1. On your Mac, navigate to "Utilities>Audio MIDI Setup".

2. Check that the DJC-4 appears in the "Audio Devices" window and the configuration is correct.

 

In case of MIDI problems:

 

3. Go to Window>Show MIDI Studio.

4. Try to remove the DJC-4 device.

5. Unplug and plug your DJC-4 device back into your computer.

Share this post


Link to post
Share on other sites

Hi Luis,

 

first of all: I am very thankful that you take your time to respond to my posting. Thank you.

 

Hi,

Follow these steps:

1. On your Mac, navigate to "Utilities>Audio MIDI Setup".

2. Check that the DJC-4 appears in the "Audio Devices" window and the configuration is correct.

I think, thats exactly the problem. It doesn`t appear in that window. I only see the built-in devices for in/output, as well as my Soundflower "devices".

I got an Audio4DJ external soundcard, which actually works. Even though those devices are no longer properly supported by NI. Anyway, the DJC4 doesn't appear.

 

In case of MIDI problems:

 

3. Go to Window>Show MIDI Studio.

4. Try to remove the DJC-4 device.

5. Unplug and plug your DJC-4 device back into your computer.

 

Double-clicking the device indicates its "online". Whatever that means in that context, but maybe the midi in/out might work.

Is it possible that the internal soundcard of the djc4 simply died?

Share this post


Link to post
Share on other sites

Is it possible that the internal soundcard of the djc4 simply died?

I'm not really sure. I think that the best thing that you can do is to try the controller in another computer to check if the soundcard still works there. The strange thing is that it worked before your OS update, what makes me feel that the internal soundcard is ok.

Share this post


Link to post
Share on other sites

Hey,

 

I have the same problem. With High OS Sierra I, the controller can't be used as a soundcard.

 

I tried the suggestions but nothing happened... This problem is really annoying.

 

Do you still have the problems or did the suggestions work?

 

Thanks!

Share this post


Link to post
Share on other sites

Hey, still not working for me... This is really annoying.

 

I tried all the suggestions, but none of them helped. :(

 

Don't think that there will be any solution to this problem.

 

I will try to go back to Sierra ...

Share this post


Link to post
Share on other sites

Have anyone solved this problem? It looks like that there are more users reporting this problem. I'm not sure where is the problem yet because my DJC4 is working fine with High Sierra.

 

Some questions:

- Is anyone using an external power supply for the DJC4?

- Have you tried a NVRAM reset?

- Could you share the Mac console report when the DJC4 is plugged (...looking for error messages)? Console program is placed in Applications->Utilities->Console.

- Could you post your Mac device model (MacBook, iMac, etc...)?

Share this post


Link to post
Share on other sites

Have anyone solved this problem? It looks like that there are more users reporting this problem. I'm not sure where is the problem yet because my DJC4 is working fine with High Sierra.

 

Some questions:

- Is anyone using an external power supply for the DJC4?

- Have you tried a NVRAM reset?

- Could you share the Mac console report when the DJC4 is plugged (...looking for error messages)? Console program is placed in Applications->Utilities->Console.

- Could you post your Mac device model (MacBook, iMac, etc...)?

 

 

Hello, sadly still not working.

 

- No

- Yes, but nothing changed

- no error found...

- Macbook Pro Mid 2010

 

I read that a lot of people have problems with MIDI and High OS Sierra. The solution could be this:

 

1. Reinstall the latest drivers for your external gear. Even if it work with all other OSX updates.

 

2. Right after the restart from the drive install you must open System Preferences>Security & Privacy and click to Allow driver.

 

I think its a security problem. Maybe this is an approach. But I still couldn't solve it...

Share this post


Link to post
Share on other sites

If you made to this post without angrily throwing away your djc you can do it now. There are no intentions whatsoever to fix this, since Gibson is broke and will be sold to whoever the f pays for it. We already paid our due.

 

How about some nifty Gibson guy reads this and puts the software on github so we can at least attempt to fix it on our own?

Share this post


Link to post
Share on other sites

Hey Luis since you are the only one who has reported that your DJC.4 works in High Sierra can you please give the rest of us some specifics of your setup? Maybe some pics of what you Audio/MIDI app looks like? What about your plug-ins or Core audio devices?

 

I've started another thread asking for ANYONE who has had success to speak up... 75 views but no one can claim success.

 

Thanks,

PT

Edited by PsarahTonen

Share this post


Link to post
Share on other sites

Have anyone solved this problem? It looks like that there are more users reporting this problem. I'm not sure where is the problem yet because my DJC4 is working fine with High Sierra.

 

Some questions:

- Is anyone using an external power supply for the DJC4?

- Have you tried a NVRAM reset?

- Could you share the Mac console report when the DJC4 is plugged (...looking for error messages)? Console program is placed in Applications->Utilities->Console.

- Could you post your Mac device model (MacBook, iMac, etc...)?

 

 

Hey Luis- Can you elucidate to us on your setup that is working on H.S.?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...