Jump to content
Gibson Brands Forums
briklot

Gibson Les Paul Standard 2017 volume knob not working as it should

Recommended Posts

Hi everyone! First of all apologies if the section is wrong, wasn't sure where to post.

I have this weird problem with my Gibson LP standard 2017. Apparently the neck volume has some weird issue. When I turn the knob down to 9/9,5, it starts buzzing and the volume itself drops dramatically. As I keep turning down, this stops from happening (please see the video below, it is clearer). Did anyone experience something similar before? Any ideas of what the problem could be and how to solve it? I’m literally crapping myself, as if there’s a problem with the push-pull board, it’s £300 flying away.... 

Here’s a video: https://streamable.com/v0iyp

Share this post


Link to post
Share on other sites

As the resident expert on burning pots while putting in new pickups, you need a pot*.  Not a huge deal, but unfortunate.  If you can solder you can fix it.

rct

 

*Full disclosure:  I know nothing of these new fangled high fallutin boards and circuit thingys in guitars.  Someone who has broken at least one of them will have to get in here about that.

  • Haha 1

Share this post


Link to post
Share on other sites
31 minutes ago, rct said:

As the resident expert on burning pots while putting in new pickups, you need a pot*.  Not a huge deal, but unfortunate.  If you can solder you can fix it.

rct

 

*Full disclosure:  I know nothing of these new fangled high fallutin boards and circuit thingys in guitars.  Someone who has broken at least one of them will have to get in here about that.

from what I've seen, they are a b**ch to repair...

Share this post


Link to post
Share on other sites
1 hour ago, rct said:

As the resident expert on burning pots while putting in new pickups, you need a pot*.  Not a huge deal, but unfortunate.  If you can solder you can fix it.

rct

 

*Full disclosure:  I know nothing of these new fangled high fallutin boards and circuit thingys in guitars.  Someone who has broken at least one of them will have to get in here about that.

RuLdUFh.gif

Thanks for a great laugh.

I have only 1 of those thingys in my 2017 SG HP. I opened the cover once and closed it right up. I have no clue how to work on them.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...