Jump to content
Gibson Brands Forums

If "Unable to initialize guitar" during firmware update - Reset DF using function 109


Recommended Posts

The computer that I am using is not connected to the internet, so maybe that is my problem.


Indeed - that will be the problem!!

You need to be Connected to the internet in order perform the Installation correctly - to register GR3, authorize Ableton Live, and perform the RIP and Dark Fire updates.



Do get an internet connection going and report back with results?

Link to comment
Share on other sites

Ok. Tried on a direct Internet connection bypassing my home router etc just in case there is a speed bottleneck and there was no difference. Today I will try to obtain a shorter Firewire & TRS Stereo cable and I will try again tonight (in 12 hours). Meanwhile if anyone can check GR3 and let me know if they see input signal on only left channel or both I would greatly appreciate that. Thank you very much.

Link to comment
Share on other sites

It still may be an internet routing / time out issue - because you are in Asia. - but I'm guessing here.


When the Dark Fire Firmware update sequence makes its attempt - I assume the Dark Fire RIP console app is attempting to contact a Gibson Server in Nashville USA - but it possibly could be a Tronical server in Hamburg Germany or a Echo Audio Server in California:




If you are on WinXP - open a DOS box, and Ping the IP address during the error CRC message - and then copy / paste the IP address in google to determine a physical location.

Link to comment
Share on other sites

Here's a dumb question




Have you tried opening the RIP Console and looking for VU meter activity on all 6 strings?



Mine shows bouncing meters when I strum - EDIT: - WHEN THE MCK IS "OUT"


Does not matter if the channel is Muted or unMuted. I see VU Meter activity as I strum all 6 strings.


Link to comment
Share on other sites

Next debug step is


Test your Mono Piezo Output


Enable the Piezo Out with the MCK

- Pull MCK OUT


- Rotate to full clockwise "PEG" position


- Push MCK "IN"


- inspect that MCK displays a "blue" Acoustic guitar icon on the top.


Now connect Dark Fire Guitar > 1/4" TRS Stereo guitar cord > Black Splitter box Dark Fire Input


Connect the Black Splitter box Piezo (Acoustic Out) and feed any amp


Do you get a Piezo sound?



This may help isolate if its your Guitar or the RIP

Link to comment
Share on other sites

Steve, I see only movement on the far left VU bar. Thought that was odd but left it at that. What might be causing this do you think?


Your earlier post re. internet routing reminded me I run McAffee stuff on these PCs so I tried one last time after disabling the firewall. It would be a shame to be getting silently blocked by the firewall as the console makes those outgoing connections but seems as though that was not my problem. Honestly I would think it would be a poor design if RIP console downloaded the DF firmware real time during upload. Knowing how flash is likely to get hosed if a timeout occurs that would be too much chance taking. I will run a network sniffer to at leats determine which server is being connected and when.


I will also do the Piezo testing recommended. Good ideas. Later when I get home. Now got to go work so I can continue to pay the bills! Keep well. Thanks for all your help.

Link to comment
Share on other sites

Ok. I managed to get a 1 mt Firewire & 2 Mt Stereo TRS and heading home. Will give it all a try but based on what you posted on another thread I'm a little worried my problem might be deeper in the RIP or the guitar itself. Will post my findings tonight.


Interesting Update


The Dark Fire indeed sends an Analog signal down the TRS "Ring" connection.


Its 8 channels of multiplexed analog signals:


1) Mag PUs

2) Mono Piezo

3) Low E

4) A

5) D

6) G

7) B

8) High E


Link to comment
Share on other sites



I was playing around more with my RIP / Dark Fire / Console


Here's what I observe


1) I make the Firewire connection to the computer, then apply DC power to the RIP with DC Power Pack.


2) I launch the RIP console - I see the Black Mixer with VU meters - no activity.


3) I connect the Dark Fire to RIP


4) My MCK is Down - no lights on MCK


5) All I see is the Far Left VU meter ("Guitar" )


6) I pull "OUT" the MCK


7) I slowly strum


8) The Tuners start to "tune"


9) I continue a light strum


10) After 10 seconds - and still strumming - I suddenly see all the VU meters (with exception of the 2 Playback channels) "dance" on the RIP Console Mixer



11) Note MCK MUST be in the "OUT" position - lights ON in order to see all VU meters for all string channels "dance".

Link to comment
Share on other sites

RESOLVED!!! Wow what a relief! I tried the gently strum for 10 seconds. No change.


Then I thought ok let me use function 109 on DF to reset the DF to factory standard and give it one last chance before I call 1-800-Gibson to ship the RIP back and guess what!!! It worked!!! I still saw only the far left VU and then tried the upload firmware and suddenly it moved to the next step and started writing firmware. I think I managed to hold my breath throughout the whole updating process!!! I am now able to verify firmware version on my DF!!!


The only things I had tweaked in the DF functions were the tuning sensitivity, Piezo off by default (to conserve power as I don't use it much). I did turn on Piezo manually before all this saga of course but some how it must be getting affected.


So lesson learned... Do a full DF reset using function 109 before attempting the firmware update if you have similar problems! Hope this helps somebody along the road. Thanks for sticking by me and guiding me through the troubleshooting process.

Link to comment
Share on other sites

I think so. I'm glad I got it sorted out too. I hope Tronical takes note of this issue. Seems like they need something like this in the DF firmware update code... If PiezoOff then PiezoSwitchOn() etc... Anyways. Now hunting the update server for fun. Glad to see the latency to Japan did not cause any issues. Keep well.

Link to comment
Share on other sites

Done. Thanks for that pointer. By the way I am having some trouble consistently getting all VU bars to move in the RIP Console. I know it works but there must be a simpler way to do this consistently other than reset the whole set plug in and strum gently for 10 seconds... Have you had this challenge?

Link to comment
Share on other sites

If I'm connected to the RIP, but stop playing, after approx 30 seconds the TDM Multiplex circuit turns off = no Hex channel signals or VU indication. This is by design, as Tronical has a few future ideas about using the TRS "ring" connection down the road - perhaps a mode where we trade hex signal processing for foot control of alt tunings - our choice - but we cant get both at once.


On mine if I start playing again, the signals returns after 3 seconds of playing

Link to comment
Share on other sites

I agree - I have tried Guitar Rig before on a 1.6GHz Toshiba M4, a HP ZD7000 with 3.2GHz P4, using a MOTU 828MKII, under WinXP , never could get the Latency low enough without popping - so I gave up.


But the RIP + GR3 and Craig Anderton's presets running on my 2.16GHz Macbook Pro with 4GB Ram = perfection.

Link to comment
Share on other sites

I had a similar problem, just could not get it to work. After lots of attempts, I realized that it was user error. Make sure that you reset the guitar using the 109 function reset, and when you do the reset be careful to follow the instructions carefully, you must confirm the reset by selecting "y". The power down the DF, and attempt to reinstall the firmware. programming is a but clumsy, but once reset you should be good to go

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...